Solución para ver el Plymouth correctamente en Ubuntu 10.10 Maverick Meerkat con tarjetas Nvidia o ATI

Al igual que ocurrió con Lucid he tenido problemas con la resolución del Plymouth al arrancar y apagar. Mi equipo tiene una tarjeta Nvidia, pero en Ubuntu 10.04 también había el mismo problema para tarjetas ATI, por lo que debo suponer que  la solución va a ser la misma. 


Instalamos estos paquetes:

sudo apt-get install v86d hwinfo

Buscamos una resolución que queramos y sea soportada por nuestra tarjeta con hwinfo.



sudo hwinfo --framebuffer

Nos saldrá algo como en la imagen



Una vez elegida la resolución que queramos en mi caso puse 1280x800 aunque la más segura es 1024x768, editamos el archivo /etc/default/grub para asegurarnos que el boot utiliza uvesafb framebuffer. Ponemos en el terminal

sudo gedit /etc/default/grub


Buscamos la línea que ponga GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash” y la sustituimos por

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x800-24,mtrr=3,scroll=ywrap"

Descomentamos #GRUB_GFXMODE, es decir, eliminamos el # y le ponemos la resolución que al resto

GRUB_GFXMODE=1280x800

Guardamos y cerramos.



Ahora editamos /etc/initramfs-tools/modules
para incluir uvesafb añadiendo la siguiente línea al final del documento y guardamos.


uvesafb mode_option=1280x800-24 mtrr=3 scroll=ywrap


Le forzamos a usar framebuffer con:


echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash


Actualizamos el grub además del initramsfs

sudo update-grub2
sudo update-initramfs -u


Reiniciamos y listo
. La primera vez tardará un poco más pero después ya funciona de forma correcta.



Saludos.

Comments are closed.